• Most Active Threads

    TZ350

    ESE's works engine tuner

    Thread Starter: TZ350

    . This is Thomas a Vietnamese race mechanic, you know that place where they have all those hot 50's and 125's are big bikes. Thomas, ESE's Race Team's Tuner is fettling number 9. adjusting the port timing for Taupo. Its hard to see but he has taped a degree wheel to the magneto flywheel...

    Last Post By: Frits Overmars Today, 02:16 Go to last post
    jellywrestler

    MotoGP 2019

    Thread Starter: jellywrestler

    I haven't been to a Moto GP as yet and reckon given others enthusiasm for them they're probably a good show? I'm thinking I should get my arse along to one in 2019 Figuring you lot would be able to enlighten me on to which meeting is the best one and why? Might as well get the inside info after...

    Last Post By: Autech Today, 05:30 Go to last post
    Mr. Peanut

    Who ruined kiwibiker?

    Thread Starter: Mr. Peanut

    This site used to crackle with activity, now it feels like a graveyard. All went downhill after they banned WINJA :yes:

    Last Post By: Beekeeper Today, 06:25 Go to last post
    JBDR

    GT 185 charging issue

    Thread Starter: JBDR

    Hi all, recently got a gt 185 two stroke from 1975. It's been a blast to ride around so far. However, It's become apparent that there is a charging issue. If anyone has experience with this issue and hw to fix it, let me know.

    Last Post By: ellipsis Yesterday, 12:35 Go to last post
    krastinrobis

    Nevis road 2-up on a R1100GS

    Thread Starter: krastinrobis

    Haven't done a whole lot of riding so this was quite the mission. Only other time I was facing proper river crossings was Macetown last year when I had to turn around halfway in because the river was too high and was gonna scoop water in the air intake.. Went from Garston side up north to...

    Last Post By: Racing Dave Yesterday, 07:31 Go to last post
    jordycash

    2002 R1 indicators

    Thread Starter: jordycash

    Hey guys, long time lurker but first time poster here. I own a 2002 R1 (5PW) and I've been having some trouble with my indicators. It has LED indicators but roughly only 1/3 of the LED bulbs in each indicator are lighting up. So far I have replaced the relay, checked any fuse I can find and...

    Last Post By: onearmedbandit Yesterday, 15:57 Go to last post
  • HEsch

    There is no available content written by HEsch