Page 2 of 2 FirstFirst 12
Results 16 to 22 of 22

Thread: Help with Suzuki RG150

  1. #16
    Join Date
    2nd January 2018 - 19:38
    Bike
    2016 KTM Duke 390, 1986 Honda CG125, 199
    Location
    Wellington
    Posts
    14
    Iím convinced itís a rich running condition. Iím also going to drop the needle to its lowest position and check the main jet size. Who knows what someone else may have done to it. BTW the chips off the end of the power valves happened when it had its massive catastrophic failure. Previous owner confirmed that he put the valves from the blown up engine straight into the rebuilt engine.


    Sent from my iPhone using Tapatalk

  2. #17
    Join Date
    2nd January 2018 - 19:38
    Bike
    2016 KTM Duke 390, 1986 Honda CG125, 199
    Location
    Wellington
    Posts
    14
    The other thing that makes me think it is too rich is it starts first kick from cold, like the choke is on. Probably stuck on, all the time.


    Sent from my iPhone using Tapatalk

  3. #18
    Join Date
    1st December 2014 - 19:23
    Bike
    89 Intruder/86 TZR250/85 RZ250
    Location
    Gisborne
    Posts
    226
    Not sure what carb you have but Iím thinking itís a Mikuni if so unscrew the choke plunger and check there is a small rubber seal in the end of it maybe missing or damaged?
    Also check to make sure the power valve jet is in place, itís in the float bowl down the tube on the side where the hose goes.

  4. #19
    Join Date
    2nd January 2018 - 19:38
    Bike
    2016 KTM Duke 390, 1986 Honda CG125, 199
    Location
    Wellington
    Posts
    14
    Some more progress today. The o ring was missing from the choke plunger, so I put one in. While I had the carb off I lowered the needle as low at it will go, top groove. Reassembled, itís better, but not perfect. The choke now seems to have an affect and at smallish throttle openings it pulls quite well. WOT still misses and surges and higher RPM. I reckon itís still too rich. Itís rideable and goes sort of OK most of the time. Iím going to see about a new main jet, factory size. The one in it doesnít have anything written on it.


    Sent from my iPhone using Tapatalk

  5. #20
    Join Date
    9th May 2018 - 18:27
    Bike
    suzuki rg 150e
    Location
    hutt valley
    Posts
    3

    hey

    did you sort it? im having very simular issues?

  6. #21
    Join Date
    2nd January 2018 - 19:38
    Bike
    2016 KTM Duke 390, 1986 Honda CG125, 199
    Location
    Wellington
    Posts
    14
    Quote Originally Posted by 2stroker04 View Post
    did you sort it? im having very simular issues?
    No, and sold it a couple of months ago. New owner re-jetted it (two sizes smaller on the main) and thought it was ok, a week later it seized again. He has since advertised it for sale.


    Sent from my iPhone using Tapatalk

  7. #22
    Join Date
    13th October 2020 - 13:56
    Bike
    Rg150, gsxf600, gsxr1300.
    Location
    Palmerston North
    Posts
    3

    Rg150

    Hi there, new to this, I have a rg150, Was all going well power came on at 8 thousand and stopped at 12500, I pulled off the the adjuster cables for the power valve, that is on the side of the engine, I would like to know how to set up the spring on the power valve shaft behind the cables, can anyone help me, thanks.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •