Results 1 to 4 of 4

Thread: Led headlights

  1. #1
    Join Date
    8th December 2021 - 21:28
    Bike
    Suzuki UZ50
    Location
    Taranaki
    Posts
    5

    Led headlights

    Hello. Iíve brought a LED headlight for my Suzuki UZ50. It fits perfectly but has little to no light when I start it up. With revs it gets slightly brighter but itís no where near as bright as even a normal bulb. Just wondering whatís wrong and how I could fix it cheers


    Sent from my iPhone using Tapatalk

  2. #2
    Join Date
    6th June 2008 - 17:24
    Bike
    The Vixen - K8 GSXR600
    Location
    Behind keybd in The Tron
    Posts
    6,514
    Quote Originally Posted by Tommy783 View Post
    Hello. Iíve brought a LED headlight for my Suzuki UZ50. It fits perfectly but has little to no light when I start it up. With revs it gets slightly brighter but itís no where near as bright as even a normal bulb. Just wondering whatís wrong and how I could fix it cheers


    Sent from my iPhone using Tapatalk
    You might need to alter the electics to make it work properly...
    A quote from a website I know nothing of: "However, XenonPro explains, you can't simply replace a halogen bulb with an LED assembly. While there are conversion kits available, they have a few drawbacks."
    . ďNo pleasure is worth giving up for two more years in a rest home.Ē Kingsley Amis

  3. #3
    Join Date
    8th December 2021 - 21:28
    Bike
    Suzuki UZ50
    Location
    Taranaki
    Posts
    5
    Cheers mate Iíll look into it


    Sent from my iPhone using Tapatalk

  4. #4
    Join Date
    2nd March 2018 - 15:32
    Bike
    1998 Yamaha R1
    Location
    Auckland
    Posts
    950
    Quote Originally Posted by Tommy783 View Post
    Hello. Iíve brought a LED headlight for my Suzuki UZ50. It fits perfectly but has little to no light when I start it up. With revs it gets slightly brighter but itís no where near as bright as even a normal bulb. Just wondering whatís wrong and how I could fix it cheers


    Sent from my iPhone using Tapatalk
    So it was a straight swap, no changes needed to the wiring? Have you checked the voltage at the bulb? If there is 12V across the bulb, it should be at full brightness. LED bulbs should have a constant light output above a minimum voltage, which is usually much less than 12V.

    Sent from my SM-G980F using Tapatalk

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •